ICEFIRE Webmaster Board  

Go Back   ICEFIRE Webmaster Board > CjOverkill Support Forum > CjOverkill General Discussion and Support

CjOverkill General Discussion and Support CjOverkill general discussion and support.

Reply
 
Thread Tools Display Modes
  #1  
Old 13th September 2011, 08:31 PM
hetpornohuis hetpornohuis is offline
Junior Member
 
Join Date: Sep 2011
Posts: 8
Default Cjoverkill install problem.!

I have a problem with my cjoverkill.
i think it is because allow_url_include and allow_url_fopen are both off.

I am getting this code.

Notice: Undefined index: install in /var/www/vhosts/6/101856/webspace/httpdocs/cjoverkill/cjoverkill-install.php on line 16 Notice: Undefined index: install in /var/www/vhosts/6/101856/webspace/httpdocs/cjoverkill/cjoverkill-install.php on line 907

Is there something that i can do to make it work
Reply With Quote
  #2  
Old 13th September 2011, 08:41 PM
hetpornohuis hetpornohuis is offline
Junior Member
 
Join Date: Sep 2011
Posts: 8
Default Cjoverkill install problem.!

I am getting this problem.

Notice: Undefined index: install in /var/www/vhosts/6/101856/webspace/httpdocs/cjoverkill/cjoverkill-install.php on line 16 Notice: Undefined index: install in /var/www/vhosts/6/101856/webspace/httpdocs/cjoverkill/cjoverkill-install.php on line 907

i think it is because both allow_url_include and allow_url_fopen are off.

Is there anyway to get past this problem?

Kind regards,
Reply With Quote
  #3  
Old 13th September 2011, 11:45 PM
ICEFIRE ICEFIRE is offline
Administrator
 
Join Date: Sep 2008
Location: Galaxy Media
Posts: 503
Send a message via ICQ to ICEFIRE
Default

CjOverkill doesn't use allow_url_fopen nor does it use url_include.

In fact it's designed to work with php safe mode and maximum restrictions.

The notice you see is because your server php installation is configured in debug mode that is not really suitable for production use.

make sure to set your php error reporting config to:

error_reporting = E_ALL & ~E_NOTICE

that could be set into the php.ini file. your server admin should know how to do it.
Reply With Quote
  #4  
Old 13th September 2011, 11:57 PM
hetpornohuis hetpornohuis is offline
Junior Member
 
Join Date: Sep 2011
Posts: 8
Default

Is it possible to change this with .htaccess file?
Reply With Quote
  #5  
Old 14th September 2011, 12:15 AM
ICEFIRE ICEFIRE is offline
Administrator
 
Join Date: Sep 2008
Location: Galaxy Media
Posts: 503
Send a message via ICQ to ICEFIRE
Default

Depends on your server config, but take a look at these instructions:

http://perishablepress.com/press/200...-via-htaccess/

http://www.bala-krishna.com/control-...with-htaccess/

Hope this helps you
Reply With Quote
  #6  
Old 14th September 2011, 01:22 PM
hetpornohuis hetpornohuis is offline
Junior Member
 
Join Date: Sep 2011
Posts: 8
Default

My hosting server canīt do anyting about the error_reporting, because i am on a shared server. Is it possible to get an unyncryptet version of cjoverkill, or is it possible to get a version where there is error_reporting = E_ALL & ~E_NOTICE in the php integrated?
Reply With Quote
  #7  
Old 15th September 2011, 03:54 PM
hetpornohuis hetpornohuis is offline
Junior Member
 
Join Date: Sep 2011
Posts: 8
Default

I need a version of cjoverkill where error_reporting = E_ALL & ~E_NOTICE is integrated or i can integrate it in the php.
Reply With Quote
  #8  
Old 15th September 2011, 07:30 PM
ICEFIRE ICEFIRE is offline
Administrator
 
Join Date: Sep 2008
Location: Galaxy Media
Posts: 503
Send a message via ICQ to ICEFIRE
Default

The rror reporting setting in php is system setting, so you cannot change it from a php script unless your server is configured really bad.

Anyways, there is the manual of the php function that allows you to disable error reporting:

http://php.net/manual/en/function.error-reporting.php

You could disable completely the error repoting before the in.php include:

<?php

error_reporting(0);
include ("in.php");

?>

Anyways, that would not really solve the problem because it's obvious that your server php is not configured properly for production use.
Reply With Quote
  #9  
Old 15th September 2011, 07:34 PM
hetpornohuis hetpornohuis is offline
Junior Member
 
Join Date: Sep 2011
Posts: 8
Default

I just fixed it in some other script by putting this: error_reporting (E_ALL ^ E_NOTICE); after <?php and it works perfectly. But becaus cjoverkill is encrypted i can not do it with this script. And becaus of that my out.php isn;t working.
Reply With Quote
  #10  
Old 15th September 2011, 07:41 PM
ICEFIRE ICEFIRE is offline
Administrator
 
Join Date: Sep 2008
Location: Galaxy Media
Posts: 503
Send a message via ICQ to ICEFIRE
Default

You can always create an alternative out.php file that includes the original one.

for example. my-out.php :

<?php

error_reporting (E_ALL ^ E_NOTICE);
include("out.php");

?>

The call my-out.php instead of out.php directly. That should do the work.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 10:13 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.