PDA

View Full Version : ip_from null


sisi
17th June 2013, 05:15 PM
Hi, I am installing a new cjoverkill copy.
I have found under the trades names this code:

Error:
OOOPS! Something wrong happened. Please reload the page you are visiting.
Transcription follows:
Column 'ip_from' cannot be null

I deleted the database and installed again. It seamed to work properly but in a couple of hours I have found the same message again.

I have not found any reference about this in google, FAQ, manual and the forum.

In the "warnings" window, into cjoverkill admin, I have this note:

Emergency Repair: Column ip_from cannot be null

Does anybody know something about this?

Thank you very much!

ICEFIRE
17th June 2013, 05:31 PM
You can safely ignore this warning.

In fact, all warnings in the warnings window can be ignored. they are there to help poinpointing server, configuration problems and bugs.

The problem you are pointing is when some specific condition hit the IP filter under some php configurations.
It affects only a given IP, in this case your IP.

Go to network settings and set bots management to be blacklist stop counting.

sisi
17th June 2013, 08:28 PM
Sorry again. Does this mean that my ip is taken as a bot? (maybe I tried to fast to add trades :D)
If I set it this up, would my site let all the bots click in my site as if they there good?

ICEFIRE
18th June 2013, 01:03 PM
Probably your IP has been taken as bot. depends alot on your anticheat protections.

Most probably it was due to too many clicks or page loads. you can see why it was filtered by clicking on the IP filter link and locating your IP there.

sisi
20th June 2013, 12:09 PM
There was nothing in the ip list.

I think I have found what happened. It was about wordpress problems.
Solution? http://bbs.icefire.org/showthread.php?p=1362&highlight=wordpress#post1362 in here. Change the code.

Thanks a lot for your patience. I think I have found in here the solution.